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Introduction 
The version 2022.1.0 release resolves known issues and includes enhancements to 
team and user maintenance, security, performance and the Windows Designer. It also 
includes small compliance updates for Australia and New Zealand. 

This release also replaces the Internet Explorer control used for displaying PDFs and 
web content with the Microsoft WebView2 component. This has environmental 
requirements which are explained in the Upgrade instructions section. 

The sections below provide full information on all of the changes included in this 
release. 
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Note about Greentree Browser support 
In August 2020, Microsoft began retiring Internet Explorer.  

As a result, Greentree no longer supports the use of Greentree Browser with Internet 
Explorer 11. If you use Greentree Browser with Internet Explorer 11, you must start using 
a supported internet browser before August 2022.  

The Google Maps used in the Greentree Browser will no longer work in Internet 
Explorer after August 2022. In Greentree Browser, this affects the Organisation and 
Contact forms. 

 

 

https://developers.google.com/maps/documentation/javascript/browsersupport
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New Features 
Manage menu access without changing 

companies 
The Team and User Enquiry form and menu item have been renamed to Team and 
User Security. 

The form has been enhanced to allow maintenance of menu access. An administrator 
can now manage menu access for teams and users across all companies on a single 
form, without changing company. 

 

Faster file importing 
Files now import more quickly. This is most noticeable with directories containing 1,000 
or more files, such as the directory that holds emails imported by eDocs. 
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Security enhancements 
Change Password window 
When a user wants to change their password, they now need to enter their current 
password before they can enter a new password. 

To change a password, go to the File menu and choose Preferences, then click 
Change Password. The new Change Password window opens. 

 
Note:  

previous releases, by going to System > System Setup > User Maintenance 
and completing the Password and Confirm Password fields. 

 

Improved lockout after failed login attempts 
The lockout feature is now more consistent, so if a user tries to log in with the incorrect 

 

This applies when logging in to Greentree Desktop, the Management console or the 
Credit Card Maintenance form. 

Hidden dropdown contents 
For read-only dropdown lists, a user can no longer use the dropdown icon to see the 
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Identifiers for Greentree Browser 
To improve security, this release changes how identifiers used by Greentree Browser 
are generated.  

Windows Designer enhancements 
This release enhances the Windows Designer to better support customisation 
windows that expand based on the size of the main Greentree desktop window. 

Note:  These enhancements were introduced to resolve issues where 
customisations could display incorrectly, with forms overlapping each other. 
To get the benefit of these enhancements, an administrator needs to open a 
customisation affected by the issue and save it. Then, check that the 
customisation works correctly by changing the sizes of the main Greentree 
window and the customised form.  

In the Position & Size section of the Windows Designer, you can edit the new Right 
and Bottom fields. The Left, Width, Right, Top, Height and Bottom fields are shown or 
hidden according to which horizontal and vertical alignment options you select. When 
you save a customisation, only the relevant settings are applied. That way, the 

 

These enhancements resolve an issue where customisations could display incorrectly, 
with forms overlapping each other. 

Updated protected earnings 
Australia only 
The protected earnings table on the HR Module Control form has been updated for 
2022. 
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Payday filing update 
New Zealand only 
IR now requires that a Tax code line record (TED) is included when sending an 
Employee details line record (DED). To accommodate this, Greentree now checks to 

Tax Codes 
Missing message: 

 

being included in the total gross earnings amount. 

Sending emails with OAuth2 
Greentree can now send emails to Exchange servers using Exchange Web Services 
with OAuth2 or basic authentication. This brings it in to line with the options for email 
retrieval from Exchange servers.   

For sending, the options are server type SMTP, which is configured using a security 
option and uses basic authentication, or server type Exchange, with either OAuth2 or 
basic authentication. The same credential dialogs and token management apply. The 
release includes new versions of the libraries GreentreeMail.dll, GreentreeMailCore.dll 
and Aspose.Email.dll. Existing email sending configuration will be converted to use 
SMTP with basic credentials and security option None or SLL Explicit, according to 
whether the prior Enable TLS/STARTTLS setting was off or on. 
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Microsoft WebView2 
The browser control that Greentree Windows client embeds in some forms has been 
replaced. The replacement uses the same WebView2 component used by the 
Microsoft Edge browser. The change removes a dependency on an older, deprecated 
Microsoft component and provides Greentree with greater security. The change 
affects only Greentree Windows client, not Greentree Browser client or other web 
applications. 

Client machines must now have Microsoft Edge WebView2 Runtime installed for the 
Greentree Windows client to display: 

• the Greentree end-user licence agreement from Help > About 
• the MYOB STP legal notice from Help > About 
• web addresses for suppliers, customers etc. 
• maps for suppliers, customers etc. 
• requests for Lean Engage feedback. 
• 3D live workflow desktop panels to display PDFs 
• Qlik workflow panels 
• eDocs displaying PDFs 
• WebView displaying the PDF View panel. 

The package adds three files to the file lists for Connection Manager settings groups. 
These files must be present on client workstations running thin client. The previous 
library ieframe.dll is no longer required and can be manually removed from file lists.  

Upgrade instructions 
Partners should inform sites that client machines will require Microsoft Edge WebView 
Runtime installed. This is present by default in recent versions of Windows end-user 
machines, but not in older versions and generally not on servers. IT departments may 
have their own policies for configuring user machines, but in the absence of their 
guidance our recommendation is to download and run the Evergreen Bootstrapper at 
WebView2 - Microsoft Edge Developer. IT departments may choose to implement 
policies that control the location of the local cache, which defaults to 

in the Microsoft Edge 
WebView2 Policy Documentation.  

Partners should also run the Connection Administration application, confirm that file 
lists include Microsoft.Web.WebView2.WinForms.dll, Microsoft.Web.WebView2.Core.dll 
and WebView2Loader.dll, and confirm the embedded browser is working: log in using 
Connection Manager, select Help > About and click on the licence link.  

  

https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section
https://docs.microsoft.com/en-us/deployedge/microsoft-edge-webview-policies
https://docs.microsoft.com/en-us/deployedge/microsoft-edge-webview-policies
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Troubleshooting WebView2 

 

running thin client, the remedy is to ensure the 
directory and included on the file list in Connection Administration. 

 

 
This error indicates the WebView2 Runtime is not present on the client machine. The 
remedy is to download and run the Evergreen Bootstrapper at WebView2 - Microsoft 
Edge Developer. 

 
To confirm, open Windows Apps & features and search for WebView: 

 

  

https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section
https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section
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Known issue 

eDoc PDF not scaling with window size 
To display an eDoc PDF at full size, click Fit to Width on the toolbar, or press Ctrl + \ on 
your keyboard. 
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Resolved Issues  
Greentree Desktop 

Service Request ID  Description 

00011187 (AU only) As part of STP Phase 2, the allowance detail code for a private vehicle 
was incorrectly set to ND. This has been resolved. The code has been 
corrected and is now V1. 

00011182 (NZ only
The t  

00011067 After using the gtINStockItemSupplier FREE function, quantity break pricing 
was removed from stock items on the Inventory Supplier Detail Maintenance 
screen. This has been resolved. 

00010691 When using Windows Designer to make Parent aspect customisations, those 
customisations could display incorrectly, with forms overlapping each other. 
This has been resolved through enhancements to the Windows Designers. For 
more information, see the Windows Designer update section. 

- On the Security tab of the HR Employee Maintenance screen, clicking Create 

already used in this dictionary  

00011179 When using Microsoft Query to retrieve data from the ODBC Exposure Tool, an 

 

00006187 When creating a CRM contact on the HR Employee Maintenance screen, an 

resolved. You can now create and maintain an HR person with a surname of 
30 characters. 

00010564 When using the Data Import Manager to import a purchase order, the import 
adds tax for lines that are already inclusive of tax, causing the line total to 
calculate incorrectly. This has been resolved. 

00005949 The AP Aged Balances report could incorrectly display current invoice values as 
negative. This has been resolved. Now, when applying AP Payment, Journal or 
Credit Note to invoices in current, previous or future periods, the Total 
Outstanding value is correct in the Total column. 

11257 
00011302 

00011418 

pays were successfully imported. This has been resolved. 

00011262 When attaching an email file to a service request, the file could be empty and 
 

00011103 
00011153 

When entering information in a search field, i
monitor screen to display the full table of options for the field, then the 
columns on the left of the table would be cut off. This has been resolved. The 
right edge of the table now aligns with the right edge of the monitor. 
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Service Request ID  Description 

00011021 Opening the AR Credit Note Entry and AR Invoice Entry forms could take a 
long time. This has been resolved. 

00010643 When using the Data Import Manager (DIM) to import AP credit notes, three 
issues would occur if negative lines were converted to invoices and the Create 

option is selected: 

• The unapplied transaction for the credit note line was  

• Details in the log file were incomplete. 

• GL AP Credit Note batches were out of balance. 

This has been resolved. 

00010243 
00010654 
00011071 

00011198 

(NZ only) Employees could be overtaxed for extra pays, including bonuses, 
back pays and termination payouts. This has been resolved. To ensure the 
correct tax code is applied when creating pays, the annualisation calculation 
now excludes any transaction types that are set as extra pays. 

00009396 
00002543 

serial/lot 

 

00010792 During an eReporting run that generates AR statements, an Accounts 
Receivable user could experience locking issues. This has been resolved. The 
report writer method that determines whether to include each customer has 

 

00010958 (NZ only) When creating a payday lodgement from the EI amendment post 
1/04/2020 interface file, the field was 
in the incorrect position.  

This has been resolved with a new Interface Name called EI amendment post 
1/04/2022. This is now the default interface on the Other tab of the Inland 
Revenue Reporting Configuration form. 

00011271 The JCSalesLineItem.myJCJobSalesCode was being populated incorrectly. This 
has been resolved, so that the myJCJobSalesCode always includes the sales 
code. 

00011227 
00011303 
00011339 

Opening a form from the Favourites or Bookmark lists could cause an error: 
 

00011309 Depreciation values could be incorrect. In a year when an asset fully 
depreciated, its value would be zero. However, depreciation would continue 
for the following year, creating an incorrect negative value. This has been 
resolved. 

Greentree Browser 

Service Request ID  Description 

00011127 For a HR user, the HR & Payroll menu could be missing. This has been 
resolved. 
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eDocs 

Service Request ID  Description 

00011145 When creating an AP invoice on the eDoc AP Invoice screen, an error could 
 

00010771 
number to the Order Number and Sales Order No fields, instead of just the 
Order Number field. This has been resolved. An updated rule is now available 
on FTP. 

00011031 On the eDoc SO Sales Order form, lines on the Stock tab would not 
automatically match after entering a stock code and quantity. This has been 
resolved. 

00009295 
00010208 
00011281 

error  

 


