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Introduction 
 

The version 2021.4 release updates the Stock Movement Transactions screen and the 
Client Installer, as well as resolving issues in several MYOB Exo Business modules. 

This release also adds a new End User Licence Agreement (EULA). To view the new 
agreement in your software, go to Help > Terms and Conditions, or Help > About, 
which includes a link to a PDF of the agreement.  

The purpose of this document is to provide essential information on the installation 
and use of this release:  

• The Installation section provides an overview of the installation process, 
including pre-installation requirements and post installation steps.  

• The New Features section describes all new features introduced in this release.  
• The Resolved Issues section describes all issues that have been addressed by 

this release.  
• The Known Issues section details any issues in this release that have been 

identified as requiring attention.  
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Installation 
Pre-Install Requirements 

Minimum system requirements for PCs running MYOB Exo Business components are 
detailed below. See the Minimum System Requirements page on the Exo Business 
Education Centre for details about the requirements and supported operating systems 
for MYOB Exo Business. 

The performance of the Exo Business system is not assured if these requirements are 
not met. MYOB cannot assure performance if the Exo Business system is installed on a 
server that is already under load from other processes, or a RDBMS that is not suitable 
for an  

Other Requirements 
Certain features of MYOB Exo Business require one or more of the following: 

• Internet access 

• Microsoft Internet Explorer 7.0 or later 

• Adobe® Acrobat Reader 7.0 or later 

Microsoft Office connection requires Microsoft Word/Excel 2016. 

Contact synchronisation requires Microsoft Outlook 2016. 

This release of MYOB Exo Business requires ExonetLib.dll version 2020.2, which is 
installed with the application. 

When installing manually with 64-bit Outlook integration, you must copy the file 
RwEasyMAPI64.exe from the Supporting Files\RapWare folder of the Exo Business 
DVD to the install directory. Register this file by running the following from a command 
prompt: 

RwEasyMAPI64.exe /regserver  

Note:  The client installer does this automatically. 

Installing MYOB Exo Business 
Information on installing and upgrading MYOB Exo Business is available on the MYOB 
Exo Business Education Centre see the following pages: 

• Installing Exo Business 

• Installing Exo Business Services 

  

http://help.myob.com.au/exo/sysreqs.htm
http://help.myob.com.au/exo/installexobusiness.htm
http://help.myob.com.au/exo/installexobusinessservices.htm
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Post-Installation 
Once MYOB Exo Business, you must configure it for use. You can 
optionally migrate data into Exo Business from another MYOB product. The 
configuration and migration processes are detailed in the MYOB Exo Business 
Implementation Guide. 

Logging in to Exo Business 
New MYOB Exo Business databases are installed with one or more default user 
accounts. When logging in to Exo Business for the first time, you must supply the 
following login details: 

For a new blank database (EXO_LIVE): 

• Default admin user = ExoAdmin 

• Default admin password = ExoAdmin 

For the demonstration database (EXO_DEMO): 

• Default admin user = ExoAdmin 

• Default admin password = ExoAdmin 

• Default demo user = demo 

• Default demo password = DEMO 

Note:  Passwords are case-  

Updating the Exo Business Database 
If you are upgrading from 2020.2 or later, the database upgrade process is trivial as 
nearly all of the changes are to the user interface.  

If however, you are upgrading from a version of MYOB Exo Business before release 
2019.4.1, the database conversion process makes extensive changes to align with new 
database technologies. In Exo Business 2019.4.1, we added Unicode support to the Exo 
Business user interface which involved changing the database to support Unicode. 

un the database update utility to apply the changes. While the process 
 to convert columns 

in the database to their Unicode equivalents. 

Before updating client databases, partners must read the MYOB Exo Business 2019.4.1 
Upgrade - Unicode Database Conversion whitepaper. The whitepaper details steps 
that you must carry out before performing the update. 

Note:  Prior to updating to Exo Business 2020.3, you must backup the database. 
The changes that the update makes to the database schema cannot be 
undone. 

https://help.myob.com.au/exo/whitepapers/MYOB%20EXO%202019.4.1%20Database%20Upgrade.pdf
https://help.myob.com.au/exo/whitepapers/MYOB%20EXO%202019.4.1%20Database%20Upgrade.pdf
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New Features 
Stock Movement Transactions Updates 

Import Progress Bar 
This release improves the performance of MYOB Exo Business when importing stock. 
It also adds a progress bar that shows you how much of the import has been 
completed. 

Also, you can now cancel an import by clicking Cancel in the progress bar window. 

 

Importing Event Reasons from a CSV File 
When importing stock from a CSV file, you can now include event reasons in the file. 
This means you no longer need to manually enter a reason in the Event Reason 
window for each stock item. Instead, the reasons are automatically added to the new 
Reason column. 

 
Note:  After saving, i  in the CSV file, you need 

to manually enter a reason in the Event Reason window. 
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Client Installer Update 
The Client Installer now lets you install new versions of MYOB Exo Business to a 
different folder, instead of overwriting the folder where MYOB Exo Business is 
currently installed. 

To choose where to install a new version, click Browse in the Select Destination 
Location window. 

 
  



 

Release Notes - Exo Business version 2021.4 Page 8 of 12 
Copyright 2021 MYOB Technology Pty Ltd. 

Permission to disconnect users 
In MYOB Exo Configurator, administrators can enable the new Can disconnect users 
permission setting for users.  

 
Users with this permission can access the Send Message to Users screen, where they 
can send requests to other users to log out or force them to log out. 

Note:  To open the Send Message to Users screen in Exo Business and Exo 
Configurator, go to File > Database Tools > Message Users. 
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Only a System Administrator can disconnect multiple users at once. They can end user 
sessions by selecting one or more users in the Online Users list, then clicking 
Disconnect User or Disconnect Users on the toolbar.  

Note:  Warn any users before disconnecting them, so that you do not disrupt a 
long running process, such as posting. 

 

To message or disconnect users 
1. Go to File > Database Tools > Message Users. 
2. In the Send Message to Users screen, click New. 
3. Complete the Name and Email fields. These details appear on the message you 

send to users, letting them know who sent the message. 
4. From the Action dropdown, select an option: 

• Request Logout  Sends users a message requesting that they log out. 
• Force Logout  Disconnects users, so they   
• Message Only  Sends a custom message to users. 

Note:  If you select Request Logout or Force Logout, then the Logout Before field 
appears. Use this field to set when the request will be sent. 

8. In the blank text field, write a custom message. 
9. Click Send. 

Note:  If a user is in a long-
log out.  
Using Runtime Parameters (posting process from the command line) is not 
supported in this release. 

 

  



 

Release Notes - Exo Business version 2021.4 Page 10 of 12 
Copyright 2021 MYOB Technology Pty Ltd. 

Resolved Issues 
Exo Business Core 

Service Request ID  Description 

CE00019519 CE00019413 When creating a sales order or an invoice for a bill of materials, the branch 
number and GL sales account would be incorrect. This has been resolved. 

CE00019738 CE00019529 Two issues with Payment Times Reporting have been resolved: 

• When generating the PTRS report, it could calculate incorrectly.  

• When duplicating or crediting an invoice for a creditor transaction, an 
 

CE00017076 CE00017066 Two issues could occur when importing data for a stock item with the Batch 
tracked and Item expires flags selected. Either the Batch Expiry field would 
be blank, with no date imported, or the field would be set to the incorrect 
date. This has been resolved.  

CE00014181 CE00014019 In the Stock Movements Transaction screen, you could save a transaction for 
batch-tracked stock items without entering a batch code. This caused the 
stock quantities and the batch quantities to be different. This has been 
resolved. Now, if you try to save a transaction without entering a required 
batch code, a warning appears. 

CE00014524 CE00014001 If GST Inclusive Pricing For Debtor and Enforce Sale Price Review when Cost 
Price Has Changed were both enabled, the margin calculation would be 
incorrect in the cost price change screen. This has been resolved. 

CE00014523 CE00013896 If GST Inclusive Pricing For Debtor was enabled, 

below the average cost. This occurred because the price was treated as GST-
exclusive, rather than GST-inclusive. Also, the warning would not appear 
when the selling price was below the average cost. These issues have been 
resolved. 

CE00007678 CE00002032 On the Sales Orders screen, free stock could calculate incorrectly for linked 
stock codes. This could trigger a stock shortage warning when supplying an 
order, even if there was enough stock for the order. This has been resolved. 
MYOB Exo Business now checks for the free stock of the selected inventory 
item, not the linked stock item. 

- A navigation issue affected some screens. For example, if a record was 
selected in the General Ledger Account Details screen, clicking the Move to 
next record button opened the record to the Budget tab. This has been 
resolved. 
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Exo Finance 

Service Request ID  Description 

- When submitting a bank feed application, the application could be successfully 

trying to Save your changes: The serve response was not in the expected 
 

Exo Job Costing 

Service Request ID  Description 

CE00017166 CE00016774 When adding a line to the purchase order for a job, the WIP would update 
incorrectly. This happened because the new line was assigned to the default 
location instead of the job costing location. This has been resolved. 

- If you edited a time in the Dates section of the Job Details screen, then saving 
and exiting would cause, the time to reset and the Due date calculation to be 
incorrect. This has been resolved.   

Exo InterCompany 

Service Request ID  Description 

- In the InterCompany module, an error occurs when downloading 

 

Exo Business Configurator 

Service Request ID  Description 

CE00019112 CE00019102 When upgrading a database that has users logged in, a warning opens
are other users currently logged on, please make sure you are the only user 

Previously, if you clicked No in the 
warning dialog box, the upgrade would still continue. This has been resolved. 

CE00010920 CE00010910 When running the Unicode Upgrader against a database, it could fail to 
recreate the indexes. This has been resolved. 

174036671151  When running a Unicode Conversion, the stored procedure, 
CleanupObjectLocks, would break if the * wildcard was present. This has been 
resolved. 
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Known Issues 
The following issues have been identified as requiring end-user attention in this 
release. 

Issue with Large Budget Reports in CRM  

 

To prevent this error, you must either delete or disable the budget.  

Potential Unicode Issue with Barcodes on Clarity Forms  

with an asset code containing Unicode characters.  

The error occurs because the PDF barcode format used by Exo Business does not 
support Unicode. You can get around this problem by changing the barcode type to 
QR code, or by stripping Unicode characters before barcode creation which solution 
works best for you will depend on the exact context of your business.  

To change to QR codes:  

1. In Clarity Report Designer, open the asset label report  
2.  
3. Under QRCodeSettings change the CharEncoding option to bceUTF8.  
4. Save your changes.  

Note:  If you plan to scan the labels, you need scanner software that can read QR 
codes.  

Print window display issue in High DPI  
In High DPI mode, some of the caption text on the new Print window for reports is cut 
off.  

Resizable Extra Fields Sections  
In the Sales Order and Purchase Orders windows, the Order Details section might 
disappear if you maximise the window, resize the extra fields, then restore the window 
to windowed mode.  

To work around the issue: 

1. Maximise the window. 
2. Resize the extra fields to be smaller. 
3. Restore the window to windowed mode. 


