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Introduction  

The latest release of MYOB Exo Payroll includes new features to help employers manage employees’ 
Annual Leave entitlements. This document provides instruction on how to apply the changes to the 
system brought on by these new features, and what employers need to do before implementing the 
new features. 

Disclaimer 

 
We recommend that you read the MBIE document “Holidays Act 2003: Guidance on annual holidays, 
domestic violence, leave, bereavement leave, alternative holidays, public holidays and sick leave” to 
better understand how to meet your obligations as an employer. If you have further questions, it is 
best to seek advice from an employment relations specialist to ensure you are meeting your 
obligations. 

Background to the Changes 

 
The Holidays Act 2003 stipulates that employees are entitled to a minimum of four weeks annual 
holiday each year. Ensuring that all employees receive their full entitlement each year is an important 
part of an employer’s obligations under the Act.  
 
MBIE states that when an employee’s work patterns change, it is important to ensure that existing 
holiday entitlements that are held in days or hours are accurately updated to reflect the employee’s 
new work pattern. If this is not done, there is a risk that an employee may not be given their full 
entitlement based on their current work pattern  
 
The Weeks Management features in Exo Payroll aim to assist employers in maintaining accurate 
entitlements when work patterns change by providing options to see balances in Weeks and 
Days/Hours units,  and automatically recalculate days/hours  leave balances when a work pattern 
changes. 

Before you start 

 
Before you turn on this feature:  
 
1. Ensure that you read and understand the documents on the MYOB Holidays Act Hub / Exo 

Payroll website to understand the requirements and how to check your leave setup and properly 
prepare your system for the new functionality.  

 
2. Read and understand your obligations under the holidays act.  It’s recommended that you review 

the MBIE Guidance Document: MBIE Holidays Act 2003 guidance on holidays and leave 

 
3. Where you are unsure of your obligations under the act,  we recommend seeking independent 

advice from an employment relations specialist,  or discussing your options with MBIE.  

 
4. Where you are unsure of your current Exo Payroll configuration and require assistance to review 

this, we recommend getting advice from the Exo Employer Services Professional Services Team 
– email enterprise.services@myob.com to arrange a booking.   

  

https://www.myob.com/nz/comms/holidays-act-hub/exo-employer-services
https://www.myob.com/nz/comms/holidays-act-hub/exo-employer-services
https://www.employment.govt.nz/assets/Uploads/d53229842c/holidays-act-2003-guidance-holidays-leave-.pdf
mailto:enterprise.services@myob.com


 
 
 

4 | MYOB Exo Payroll – Activating Weeks simplify success 

Setting up a Test Company  

Switching to Weeks Management is a substantial change, and there are various areas to check and 

reconcile through this process. It’s recommended to work in a test company first to ensure that you are 

confident in the process before enabling the Weeks Management options in your live company data.  

In your live company, go to File > New Test Company to replicate this company into a test database.  

 

On restarting of Exo Payroll, on your login screen change the Display setting to All Companies, and 

you will see your live company plus a test version of it prefixed by the word TEST_ 

 

You can make any changes you like in this test company and it won’t affect your live payroll.  

If you wish to update it with up to date pay information at any stage, just log in to the Live company and 

go to File > Refresh Test Company 
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Define a Week and Check Rate Comparisons 

The Holidays Act 2003 and MBIE guidance Lead us to managing leave in weeks; 4 weeks entitlement, 

weekly balances and weekly rates.  

To enable employees to take part weeks off (i.e. take days or hours) it’s important to know what 

constitutes a week for an employee,  in order to reduce the correct portion of a week off their entitlement,  

and to pay the correct portion of a weekly rate.  

Exo Payroll version 2020.06 allows us to define a week for an employee to automatically calculate the 

“Three P’s of Annual leave” – Provisioning of entitlement in weeks, Portion of weeks paid, and 

Payment of leave taken as a portion of weekly rates.   

The new Exo Payroll feature Agreed Definition of a Week enables a user to define a week for an 

employee and uses this to determine a portion of a week when an employee takes leave,  for the 

purposes of reducing the balance,  and paying a portion of the weekly rate for the time taken.  

Before turning on Weeks Management it’s important to set the employees Agreed Definition of a 

Week (referred to in this document as DOW) and to review the employee’s entitlements and rate 

calculations.  

Set Agreed Definition of a Week 

 

1. To set the DOW for an employee, go to their Employee Maintenance > Standard Pay tab 

2. Click on the [Days/Hours Paid] button and set the number of days or hours that represents a week 

for your employee i.e. this may be 5 days for a standard full-time team member.  
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Notes:   

• If you are unable to define a week for an employee, employer and employee may come to an 

agreement on what a week is for the purposes of provisioning and payment of Holiday Pay.  It’s 

important to seek advice from an employment relations expert and/or refer to MBIE guidance 

for assistance where this is not clear.  

• Where an employee is Fortnightly or Monthly, your Number of working days for the period will 

be different to the Agreed Definition of a Week field.  I.e. a Fortnightly employee may show 10 

days in the Number of working days field, and 5 days in the DOW field.  

Review Holiday Pay Rates – All Employees 

 

Currently Exo Payroll derives Holiday Pay rates using Gross Earnings divided by the number of 

days/hours recorded for the period – this is now switching to a weekly calculation (Gross / weeks).  

Please refer to the Annual Holiday Rate Calculations document on the holidays hub for more 

information.  

 

To compare your current Days/Hours holiday pay rates with the weeks equivalent that will be applied, 

use your Holiday Pay – Rate Comparison Report View to check all employees at once.   

Report views enable users to customise various reports to show and hide selected fields and 

information on the reports.  

  

1. To access report views, go to the Reports menu and select Report Views  

2. Select the Holiday Pay – Rate Comparison report view 

https://www.myob.com/content/dam/comms/documents/holidays-act/exo/Annual%20Holiday%20Rate%20Calculations.pdf
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The report view will be created with a standard set of fields: 

 

Use the Filters at the top as follows:  

Department  Filter the employees on the list by department  

Cost Centre Filter the employees on the list by their default cost centre  

Employment Status  Filter by All employees, permanent only, or casual  

Sort Order  Select the field that you wish to sort by, and whether you wish to sort 

descending or ascending 

Custom Views  View:  Use this to select a saved view (or set of fields)  

Use this button to add a new view to customise with set fields 

Use the field chooser button to select the fields that you wish to 

see in this view.  

Where you have selected new fields,  use the Save button to 

save the changes to your view.  

 

Setup Rates Review Report 

Set up a new report view to compare your current Daily/Hourly rate to the weekly rates for:  

• Standard Pay  

• 4 Week Average  

• 52-week Average Weekly Earnings  
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We recommend selecting all fields that will enable rate checks, including but not limited to the following:   

• Employee Start & Last Pay Dates  

• Ordinary Weekly Pay method  

• The Standard, 4-week & 52-week average rates in Days/hours 

• The Standard, 4-week & 52-week average Weekly Rates 

• The new Definition of a Week field 

 

You may add in any other detailed fields that you like, then Export the report to Excel.   

 

• Divide your Weekly Rates by your Definition of a Week value to get Daily/Hourly Rates, then 

compare against the current daily or hourly rates.  

 

• Where there is a variance, investigate to determine why there is a variance i.e.  

o The employees Definition of a week has been set incorrectly  

o The employees Days Paid or Hours Paid history has been tracked incorrectly  

o The employee is a Pro Rata or % entitlement Employee 

 

• Go to the employees’ maintenance and make any changes required, then re-run the report.  

Continue with this process until you are happy with the results and are ready to turn on Weeks.  
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Review Holiday Rates – Per Employee  

If you are activating weeks for one employee at a time, you can see an employee specific rate check 

on their Employee Maintenance > Holiday Pay tab > Compare Rate button.  

 

 

Click on the Compare Rate button to view the employees current Daily or Hourly rates, versus the new 

Weekly rates that will be applied.   
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• Where there is a variance, investigate to determine why there is a variance i.e.  

o The employees Definition of a week has been set incorrectly  

o The employees Days Paid or Hours Paid history has been tracked incorrectly  

o The employee is a Pro Rata or % entitlement Employee 

 

• Go to the employees’ maintenance and make any changes required, then re-run the report.  

Continue with this process until you are happy with the results and are ready to turn on Weeks.  

 

Review Current Balances – Simple & Complex Equations 

Where an employee has no Outstanding or Advanced Days/Hours entitlement, switching on weeks will 

simply adjust the current years accrual, based on their defined entitlement Days/Hours, and their DOW.  

 

Where an employee has Outstanding balances from previous years, or leave paid in Advance, or has 

been on a variable work pattern over time, it’s important to check balances to ensure that they 

accurately represent the current weeks balance for the employee.   

Standard Work Pattern Employees 

Where employees have been on a consistent work pattern for their length of employment, a simple 
calculation can be done to check balances before switching to weeks 
 

1. Number of Years (at least 6 years from last Anniversary) 

2. X (Days/Hours per week x 4 weeks) 

3. - Days/Hours you have paid Holiday Pay 

4. = Balance 

Variable Work Pattern Employees 

Where employees have been on a highly variable work pattern, set to % or Pro Rata accrual 
methods, or where the employee has had multiple work pattern changes throughout their length of 
service, checking balances may be more involved.  
 
Considerations:  
 

• What should the employee's total weekly entitlement be for their length of service,  where 
there have been work pattern changes 

 

• Can you determine portions of weeks taken at the time of taking leave?  I.e. Do you have 
enough data to make determinations about work patterns for the employee i.e. Rosters, 
Timesheets, Agreements ... 

 

• You may need to complete a more involved review of total provisioning and payments made 
in the past  

 

• Do you have a Mandatory Closedown – does this impact your provisioning for anyone who 
started prior to a closedown.  
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For more involved calculations consider the following:  
 

1. Years of service x 4 weeks = total entitlement in weeks 
 

2. Review all leave taken - determine the portion of a week taken based-on the employees work 
pattern at the time. 

o I.e. Employee took 3 days in January 2019 = 1 week taken as per work pattern in 
2019 

o Employee took 5 days in January 2020 = 1 week taken as per new work pattern in 
2020 
 

3. Total weeks entitlement – weeks taken = current weeks balance.  
 
4. Current Weeks Balance x current Work Pattern (DOW) = Current days/hours balance 

 
5. Adjust outstanding / advanced days where required to get correct days/hours balance before 

converting to weeks 
 

In all cases, seek advice from an employment relations expert if you are unsure how to proceed, and 
it is recommended to review MBIE’s Positioning statement:  Estimating the Value of Holidays Act 
2003 Underpayments. www.employment.govt.nz  
 

 
 

Enable Weekly Settings  

Enable Weeks for Holiday Pay 

 

Exo Payroll includes a “master switch” setting that enables the calculation of Annual Leave Entitlements 

and Rates in weeks. Activating this setting activates all the other settings in the system relating to 

weekly Holiday Pay. 

Activating the setting does not automatically switch all employees to weekly Holiday Pay calculations, 

this can be done at the employee level. 

 

Before activating this functionality, you must make sure all pays in the system are closed.  

 

1. Go to Utilities > Setup Exo Payroll > Leave Management Setup  

2. Under the Holiday Pay Options section tick the option “Calculate Holiday Pay in Weeks” 

 

http://www.employment.govt.nz/
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3. Click [Ok] to the message to review the weekly rates of all employees 

4. The Holiday Pay – Rate Comparison report view will appear.  It’s recommended that you export 

this to review and hold on file. (Refer pages 5 – 9 in this guide)  

5. A message will appear confirming the change and confirming that you have read and understood 

the instructions to manage weeks in Exo Payroll.  Tick the box and click [Ok] to activate Weeks.  

 

Set Recalculation Method for Days/Hours Balances 

 

Once weeks is enabled, you will have the option to turn on weeks management for employees. For 

those employees you will see entitlements and balances in Days or Hours as you currently do, along 

with the corresponding value in weeks.  The aim of this is to allow employees and payroll administrators 

to continue to see and request leave in days or hours, with Exo Payroll converting this to a portion of a 

week for rates calculations and managing balances.   

 

When an employee’s work pattern changes, the Agreed Definition of a Week value should be updated. 

Exo Payroll will prompt to update the employee’s days/hours holiday pay balances and entitlements 

based on the employee’s new week.   The system will calculate the necessary adjustments to the 

entitlements and balances in Days or Hours based on the new Agreed Definition of a Week.  

To provide flexibility, Exo Payroll includes settings to determine how you want the system to behave 

when an employee’s Agreed Definition of a Week changes and a recalculation of entitlements is 

triggered. 

 

The options are as follows:  
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Behaviour when changing Agreed Definition of a Week (DOW):  

 

1. Always recalculate the Annual Leave balances in Days/Hours  

This option requires no intervention - on changing DOW, the employees Weeks balance will stay 

static and Exo Payroll automatically adjusts the days or hours balances to reflect the new week 

without any prompting.  The employee will still be entitled to the same value of weeks as they were 

prior to the change.  

 

2. Always ask whether to recalculate the Annual Leave balance in Days/Hours 

On changing DOW Exo Payroll will always warn about the change before recalculating 

entitlements. The user can then choose whether to apply the recalculations to the Days/Hours 

balance or not.  

Note: Not applying the recalculation of Days/Hours may result in an increase or reduction of the 

Annual Entitlements and Balances in Weeks.  Please review carefully before choosing not to 

recalculate.  

 

3. Ask only when the Annual Leave balance in Days/Hours will be reduced 

Exo Payroll will warn about the change to weeks balance only when an employee’s entitlements 

in hours or days is about to be reduced. A change to the Agreed Definition of a Week that will 

increase their entitlement (or leave it the same) will happen automatically. 

 

Note: As above, choosing not to apply the recalculations may result in an increase or reduction of 

the Annual Entitlements and Balances in Weeks.  In addition, not applying the recalculations 

consistently can impact an employee’s balances and rates.   

Please choose carefully before choosing not to recalculate, and refer to MBIE guidance regarding 

reducing work patterns and entitlements 

 

Select the recalculation method that applies to your business and click [Save:F10] 

 

Activate Weekly Settings for employees 

All new employees will be set to Weeks by default, unless you remove the default tick on the Leave 

Management screen.  When applying weeks settings to existing employees, there are 2 options:  

1. You may choose to apply the weeks settings to ALL permanent employees at once.  

2. You can opt to set weeks on for specific employees in the Employee Maintenance screens.   

 

Once you have reviewed your DOW settings and are ready to activate weeks for your employees, follow 

the steps below.  
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What employees cannot be converted to Weeks?  

 

Note that Employees on the following settings cannot be converted to weeks:  

• Casual employees, set to Pay casual holiday pay each pay  

• Any employees on a Permanent Part Time/Pro Rata method 

• Employees accruing holiday pay on the Percentage Entitlement Only method 

• Employees on a Holiday Pay Group 

 

It’s advised that you review any employees with these settings and reset them to the most appropriate 

Holiday Pay method.  

Once these settings are removed, you will be able to set the employees to a Weeks management 

setting.  

 

Note:  Holiday Pay groups are not supported in a weeks-based setting.  Where you have an employee 

who has a service based entitlement increase (e.g. 4 weeks per year to 5 weeks per year after long 

service) it is recommended that you remove the holiday pay group,  and set a reminder note for the 

Admin payroll users to manually adjust the entitlement once the employee becomes entitled to their 

additional weeks.  
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Activate all permanent employees 

Once you have reviewed the employee rate comparisons as per pages 5 – 9 of this white paper, you 

can activate Weeks for all permanent employees in one process.  

Go to Utilities > Setup Exo Payroll > Leave Management Setup 

Click on the Activate all existing employees button 

 

A pop up will appear stepping you through the following processes:  

 

Backup  You must create a backup prior to completing this option.  This 

means that if for any reason you need to reverse the process, 

you can simply restore to this backup.  

Rate Comparison  Click Rate Comparison if you wish to review the rate comparison 

report  

Update  Click Update to calculate and apply holiday pay entitlements and 

rates for all permanent employees who are not on any of the 

methods noted above.  

Note: You must review these employees separately and remove 

them off Pro Rata/% based methods to activate weeks.  

Close  Click Close if you wish to close without updating all employees 

to weeks.  

 

Once this process is complete, all Permanent employees will now have Holiday Pay set in weeks for 

Entitlements, Balances and Rates.    
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Activate Single Employee  

 

To activate specific employees, go to the Employee Maintenance > Holiday Pay tab 

Once you have reviewed the rate comparisons as per pages 5 – 9 of this white paper, click on the 

Calculate Holiday Pay in Weeks tick box.   

 

A message will appear confirming that you have checked the rates first.  Click [Ok] and the compare 

holiday pay rate screen will appear.  

Review and click [Exit] – a message will appear confirming Are you sure you want to calculate holiday 

in weeks for this employee?  

Click [Yes] and Exo Payroll will convert the new employee to Weeks.  

 
 
Note:  This function is reversable,  if you revert back to days/hours you will need to review and 
reconcile your leave balances for the employee to ensure that the correct balances are held.   
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New Weeks based Holiday Pay Screen 

Once weeks is activated for your employee, you will now see new fields on your employees Holiday 

Pay screen:  

 

1. Annual Entitlement Weeks displays the total weeks the employee is entitled to.  This value is 

calculated based on the Annual Entitlement Days / DOW 

 

2. New [Leave Without Pay] options are available for weeks-based employees, that allow better 

management of periods of leave without pay greater than 1 week.  Please refer the Help menu 

or the whitepapers on our knowledgebase for more information.  

 
3. Weeks Balances are now calculated for current year Accrued, Outstanding and Advanced 

values.  These Weeks values are based on the Current, Outstanding days/hours divided by the 

Definition of a Week to get the correct Portion of a week.  

 
Note: Where Holiday Pay is managed in Days or Hours, it’s important to adjust leave entitlements and 

balances when an employee’s work pattern changes.  If this has not been done previously, it’s important 

to review the Outstanding and Advanced Days to ensure that they reflect the correct weeks the 

employee is entitled to.   

It’s recommended to review the documentation on www.myob.co.nz/holidaysact for more information,  

and consult an employment relations specialist for further advice.  

 

 

 

 

  

http://www.myob.co.nz/holidaysact
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Reporting Updates  

The following reports and report views have been updated:  

• The Custom Payslip will now show a Portion of a week taken and provides the option to show 

weeks balances for weeks-based employees. Note if you aren’t already using the Payslip – 

Custom report, we recommend switching to this option.   

• The Holiday Pay report will show whether an employee is set to Weeks or Days/Hours 

• Holiday Pay Report Views has been updated to provide additional fields to show weeks 

information  

• Holiday Pay Report View has been updated to provide standard Weeks and Days/Hours Report 

View Options  

• A new Agreed Definition of a Week Change History report view will provide an audit trail of any 

changes to an employees Agreed Definition of a week and recalculations of balances and 

entitlements.  

Note: Access to the new report views is controlled by the existing report access to the Holiday Pay 

Report in User Security.  

 

 

Next Steps 

For further information on managing entitlements and payments in weeks please see the following 

whitepapers on our Education Centre/Whitepapers 

 

• Provisioning Annual Holidays in Weeks and Managing Work Pattern Changes  

• Holiday Pay Processing in Weeks  

• Managing Leave Without Pay 

 

 

 

 

http://help.myob.com.au/exo/espapers/index_nz.htm

